Note
Microsoft references to Phone System Licence or Teams Phone Licence are both related to the Direct Routing ability required to pass calls to third parties.
Overview
During the sync process the Microsoft platform may return an error.
If this occurs the Sync Now button may show Sync Failure.
Users may also see an error message under the button or in the diagnostic output:
Cause
If the Sync process takes longer than 15 minutes, and so times out, or returns the error message
“Setup partially complete, domains not ready in Office 365” for one or more domains:
Then this means that Microsoft have not ‘voice activated’ the domains.
Note: This has no connection to the Microsoft Admin Center status which indicates that the domains are “Not Connected to Service”
Solutions
- Allow additional time for the domains to activate, the service has left these domains in a state to be activated as soon as Microsoft can perform this action.
- Regularly re-run the Sync Now process to check the activation status of the domains.
This can sometimes take several hours.
Escalation
If, after several hours the error persists, then customers should re-initialise the Teams service with new domains for Microsoft to activate.
Note: This will reset the time period needed to activate domains.
Re-initialise the Teams service by:
- Removing any domains that have already been completed in the Teams Admin Centre – new ones will be created.
- Delete the Teams service by clicking the trash icon on the Teams page on the portal:
3. Click ‘Enable Sync’ again.